Data Stores having issues.

Incident Report for TopRobloxStatus

Resolved

Issues fixed data stores are back up!
Posted Apr 19, 2022 - 05:33 HST

Investigating

Data Stores will be back soon.

PLEASE DO NOT JOIN ANY GAME HAVE DATA STORES IN IT, YOU MAY LOSE YOUR DATA. ⚠️
Posted Apr 19, 2022 - 03:20 HST
This incident affected: Data Stores.