Issues with website

Incident Report for TopRobloxStatus

Resolved

It should be fixed now.
Posted Apr 17, 2022 - 06:14 HST

Monitoring

It may be fixed. If not please tell us on our twitter.
Posted Apr 17, 2022 - 03:45 HST

Update

Roblox is saying nothing about this issue.
Posted Apr 16, 2022 - 22:55 HST

Investigating

The website started having issues at 7 AM GMT and it still having issues
Posted Apr 16, 2022 - 22:55 HST
This incident affected: Website.